printlogo
http://www.ethz.ch/index_EN
Informatikdienste der ETH Zürich
 
Deutsch English

Compatibility

Post Polybox.ethz.ch

More details in the ITS Blog. See also the comments in the German Post.

Problems or Questions

The ITS Service Desk is available for assistance.


Which Internet browsers are supported by polybox?
We recommend the following browsers: Internet Explorer (IE 10 or higher), Safari (6.0.4 or higher), Firefox (21.0 or higher).


Which operating system is supported by polybox?

We recommend the following operating systems: Windos 7, Windows 8, Mac OSX 10.7 and higher, Linux.


Does polybox also work with my smartphone or tablet?

An ETH customized app is available for mobile devices (iOS / Android). You can download and install this app on your mobile device via web browser. For detailed instructions, see the heading Guide/ Installation.

top